Back to overview
Downtime

Service unavailable

Aug 28 at 11:00pm CEST
Affected services
US

Resolved
Aug 29 at 08:57am CEST

All services have been restored.

Updated
Aug 29 at 07:45am CEST

Services are being restored and coming back online

Created
Aug 28 at 11:00pm CEST

We are experiencing a service interruption in the US cluster. The team is investigating.