Back to overview
Degraded
Some Applications are not available
Nov 18, 2025 at 9:30am UTC
Affected services
Europe
Resolved
Nov 18, 2025 at 10:00am UTC
All applications are back online
Affected services
Created
Nov 18, 2025 at 9:30am UTC
Some Applications on a dedicated Host were not available
Affected services