Back to overview
Resolved
Some Applications are not available
Jun 30, 2026 at 10:00am UTC
Affected services
Europe
Resolved
Jun 30, 2026 at 11:40am UTC
All applications are back online.
Affected services
Created
Jun 30, 2026 at 10:00am UTC
A single host on Europe is affected. We're working on a solution
Affected services